martes, 12 de octubre de 2010

SOLUCION para VMware Server 2.0.2 "vmnet0 is not running"!!! Ubuntu Desktop 10.04, kernel 2.6.32-25

Bueno esta solución debo admitir que me causo un dolor de cabeza pero después de mentarle a "la autora de sus días" a VMware Server 2.0.2 bajo kernel 2.6.32-25 utilizando Ubuntu 10.04, al fin idee esta forma de poder hacer funcionar la interfaz vmnet0 cuando nos aparece "vmnet0 is not running" sin necesidad de parchar el vmware-config.pl o reinstalar vmware y no se que tantas cosas mas postearon en algunos foros que la verdad gracias por las atenciones, que si bien no me dieron la respuesta correcta me hicieron comprender el comportamiento que vmware lleva a cabo de una forma no visible al ojo humano.
en fin ya fue mucho intro.

Espero mi humilde aporte pueda ayudarlos en sus días de insomnio y continuo aprendizaje ya que sin este par elementos que tendría de divertido esto? ;)

los pasos son los siguientes:

1ER EJEMPLO PUENTE CON TARJETA INALÁMBRICA
Paso 1.- crear un puente con la interfaz que deseamos utilizar

sudo /usr/bin/vmnet-bridge -n 2 -d /var/run/vmnet2-bridge-0.pid -i wlan0

Paso 2.- levantar la interfaz que se desea utilizar

sudo /usr/bin/vmnet-netifup -d /var/run/vmnet-netifup-vmnet2.pid /dev/vmnet2 vmnet2

NOTA1: En el Paso 1, por que utilice el valor 2 en el parámetro -n ?. Simple es el ID que le corresponde a mi interfaz bridge para la red inalámbrica que se crea al hacer la instalación de VMware Server,
NOTA2: en el Paso 2, utilizo /dev/vmnet2 ya que vmnet1 pertenece a HostOnly y vmnet8 a NAT

2DO EJEMPLO PUENTE CON TARJETA ETHERNET
Paso 1.- crear un puente con la interfaz que deseamos utilizar

sudo /usr/bin/vmnet-bridge -n 0 -d /var/run/vmnet0-bridge-0.pid -i eth0

Paso 2.- levantar la interfaz que se desea utilizar

sudo /usr/bin/vmnet-netifup -d /var/run/vmnet-netifup-vmnet0.pid /dev/vmnet0 vmnet0

Bien solo me queda decir que no es necesario reiniciar nada en VMware, solo aclarar que es necesario que las maquinas virtuales estén apagadas antes de llevar a cabo este procedimiento, y claro!!!! MUY IMPORTANTE!!! agradecer no cuesta nada deja un comentario siempre son bienvenidas las dudas, comentarios y/o sugerencias. :)

por el momento es todo y repito espero poder haber ayudado a alguien con este post (Hora de redacción 12:13AM jejejeje )

Saludos desde Hermosillo Sonora, México

10 comentarios:

Anónimo dijo...

Muchas gracias por el post. Es necesario ejecutar esos comandos luego de cada reinicio del equipo?

Jimmy dijo...

Así es "Anónimo" es necesario que lo hagas cada ves que reinicias el equipo. y aunque a primera vista es algo tedioso te recomiendo hacer un script bash con atributo de ejecucion (chmod +x myScript )y guardarlo en el directorio /etc/init.d y por ultimo hacer que este script se ejecute cada ves que se reinicia el equipo mediante "update-rc.d", la linea seria para esto quedaria mas o menos asi: "update-rc.d myScript defaults", NOTA: no olvides agregar un switch en tu script con las cadenas start|restart, stop, y posiblemente status :). espero te sea de ayuda.
PD: esto lo e probado con ubuntu y es un echo que sera la misma historia con debian saludos :)

RAMA KRISHNA dijo...

Hi Dijo

I am getting same issue. I have windows xp and Linux is configure on vmware. I could not able to connect from one machine to another machine. I can directly login to my Linux which is configured on VMware.

Below is the error message:

the network bridge on the device vmnet0 is not running. The virtual machine will not be able to communicate with the host or with other machines on your network. Virtual device Ethernet0 will start disconnected.

Regards
Krishna

RAMA KRISHNA dijo...

I am facing same issue. I could not able to connect from other machine to my vmware linux.

the network bridge on the device vmnet0 is not running. The virtual machine will not be able to communicate with the host or with other machines on your network. Virtual device Ethernet0 will start disconnected.

Regards
Krishna

Jimmy dijo...

hola RAMA KRISHNA, good afternoon.
regarding your problem, I note that vmware starts by default with the network interface vmnet0 in offline mode. so what I did was first create a bridge to the physical interface with the command vmnet-bridge and began to run vmnet-netifup command, which has been the version of vmware ifconfig.

CHECK this example:
"2DO EJEMPLO PUENTE CON TARJETA ETHERNET"
1th step:
sudo /usr/bin/vmnet-bridge -n 0 -d /var/run/vmnet0-bridge-0.pid -i eth0

2nd step:
sudo /usr/bin/vmnet-netifup -d /var/run/vmnet-netifup-vmnet0.pid /dev/vmnet0 vmnet0

I hope I've been able to help in any way if my answer was not clear, feel please, tell me. Greetings

PS: with this we use your card as a bridge vmnet0 as vmnet8 vmnet1 default and are configured as HostOnly and Nat, respectively

Jesus Rosales dijo...

y para windows? como lo reparo?

Jimmy dijo...

hola jesus, la verdad lo desconosco. nunca me sucedio con windows, una disculpa saludos! =)

Anónimo dijo...

Jimmy esta bien chingon pero no entiendo nada... espero cuando sea grande ser como tu...

Manuel Ramirez dijo...

Hola amigo, el aporte de ud fue en el 2011 y quiero decirte que hoy en el 2012 ha sido de mucho ayuda!! muchas gracias!!

un saludo!
att:
Manuel Ramirez
manuelx7@gmail.com
@manuelx007

Manuel Ramirez dijo...

Hello my friend!!

Tu post fue en el 2011 y hoy en el 2012 me ha sido de mucha ayuda!! muchas gracias!!!
muy agradecido!

cualquier ayuda estamos a la orden con linux!!!


Saludos!!!!